frsky uk forumA self-help group for anyone having problems or indeed anybody that can help with FrSKY products.
Setting up Neuron E...
 
Notifications
Clear all

Setting up Neuron ESCs

Barry Cole
(@barrycole)
Member Admin

I have used quite a few Neuron ESCs, and generally find them very good. The setting up using the BLHeli32 program takes a bit of getting used to, and you do need a USB adaptor to connect to your laptop.

 

Most of mine have been used on electric gliders, and for these, I have only adjusted the max and Min Throttle settings to 1000 and 2000 which matches the settings on FrSky Open TX radios.

 

I have used a couple of them to control the motors on onboard starters, for Zenoah 62 engine on my Glider Tug, and a Zenoah 26 engine on a Motor Glider. On these I found the motor would not start, and I had to increase the “Ramp up power” setting from the default 50% setting to 100%. I put this down to the motor starting in a stalled condition as it tried to get the Zenoah over compression.

 

Now to the present, I am just assembling a Dynam Spitfire, and although it comes with an ESC, I wanted to change the ESC so that I could get the telemetry and know how much charge I am using out of the battery.

 

A test with the supplied ESC at full power gave 6000RPM at 27Amps. However when I fitted the Neuron I got about 3000RPM at 8Ammps.

 

After much checking and re-testing, I found that I had to set the Ramp Up power at 100%, to get the same results as the STD ESC. I can only put this down to the motor supplied with the Kit.

 

There has always been one thing that bugged me about these ESCs, which I guess is down to BLHeli. That being the regenerative braking you get when you close the throttle. This is nothing to do with the "Brake on Stop" setting, which just holds the motor still for folding props to fold. If you snap the throttle shut the motor is braked to almost stopped, quite viciously, to the point where I always used a 1 second slow setting on the throttle channel to make the deceleration of the prop slower.

 

Now I find there is a way to get rid of the regenerative braking. It seems to be well hidden, and only shows up when you have an ESC connected. If you look at the two Screen shots below, No-01 shows the screen as you get it when you open BLHeli32, and No-02 shows the screen when you have the ESC connected, “read” (Note it always says Neuron 40, as the firmware is the same in all sizes)

 

Under the "Brake on stop" option, magically appears "Non Damped Mode" This is a bit of a double negative situation, as to get rid of the regenerative braking, you have to turn this option ON.  I tried it, and it works. Motor now just freewheels down without any braking.

Note, If you do not see the "Non Damped Mode option, you need to get the latest version of BLHeli32

Screen 02
Screen 01

 

This topic was modified 4 weeks ago 2 times by Barry Cole
Quote
Topic starter Posted : 04/01/2022 4:25 pm
Rich bago liked
Share: