frsky uk forumA self-help group for anyone having problems or indeed anybody that can help with FrSKY products.
Notifications
Clear all

RX6R binding & connection problem

philmoz
(@philmoz)
New Member

I hope someone here can help me with a binding issue on an RX6R receiver with a QX7S transmitter.

The QX7S is running the ACCST 2.1.0 XJT firmware (FCC version).

It binds and works correctly with an X6R receiver.

However with the RX6R, after binding and powering everything up the receiver always goes into failsafe mode.

Process:

- Power up QX7S, select model, start binding

- Power up RX6R with bind button pressed - all green and red light up, then I get blue and green led on and red flashing. According to the manual this means binding successful.

- Power down both

- Power up QX7S, then RX6R. RX6R immediately goes into failsafe mode - red led flashing, green and blue off.

I have tried flashing the RX6R 2.1.1 firmware as well as the 2.1.0 firmware onto the receiver but nothing seems to work.

 

Quote
Topic starter Posted : 12/11/2020 9:36 am
Topic Tags
philmoz
(@philmoz)
New Member

Never mind.

I re-flashed the 2.1.1 RX6R firmware and now it is working.

 

ReplyQuote
Topic starter Posted : 12/11/2020 9:21 pm
Barry Cole
(@barrycole)
Active Member

Phil,

Why are you running FCC RF??

ReplyQuote
Posted : 29/11/2020 9:52 am
philmoz
(@philmoz)
New Member
Posted by: @barrycole

Phil,

Why are you running FCC RF??

I don't live in the EU.

ReplyQuote
Topic starter Posted : 29/11/2020 10:02 am
Barry Cole
(@barrycole)
Active Member
Posted by: @philmoz
Posted by: @barrycole

Phil,

Why are you running FCC RF??

I don't live in the EU.

I should have guessed. How is it in upsidedown land

ReplyQuote
Posted : 29/11/2020 2:49 pm
Share: