frsky uk forumA self-help group for anyone having problems or indeed anybody that can help with FrSKY products.
Clear all

[Sticky] Horus X10

2 Posts
2 Users
Posts: 185
Reputable Member Admin
Topic starter
horus x10(0)(0)

The FrSky Horus X10S and X10 are the latest transmitters to join the FrSky family. They both carry on all of the features of their predecessors, while each model has its own unique advantages. The X10 series is lighter than the X12S, and its good ergonomics mean it is vey comfortable to hold and hangs from the from the neck strap at the correct angle. The X10 and X10S have the built-in iXJT+ module, two internal antennas mounted at 45° operating in dual path diversity mode, or a 2dB detachable external antenna with antenna detection and SWR warning functions.

They feature an industrial 480 x 272 TFT daylight readable colour LCD screen, the best in the business. The large screen and encoder wheel make navigation and programming significantly faster and easier than on an X9D.

They come with FrSky’s own easy to use FrOS (operating system) and of course, support OpenTX as well. The X10 series also inherits the wireless trainer system.

They have improved battery life with a 2600mAh Li-ion battery charged by an internal smart charger, giving a runtime of approximately 9hrs between charges. A JR style module bay is built into the back of the radio that can run different transmitting modules.

The Horus X10 has M10 hall sensor gimbals with adjustable sticks. The gimbals have 4 ball bearings.

All files relating to the Horus X10 including manuals and OS updates can be found here:

Posted : 11/04/2019 9:41 am
Topic Tags
Posts: 3
New Member


I have been trying for days now to update the IRSM Firmware in my Horus X10 transmitter with ISRM_S_X10S.frsk, (147KB).

I have Open TX -x10 installed with "internalaccess" enabled.

Under the MODULES / RX VERSION the Internal module reports "No information"

I have followed every step of the instructions in great detail but when it come to "Flash internal module" , I get the information "Device Reset", then the message "Device not responding [RTN]"

I have also tried with "ISRM-S-X10S_2.1.0.frsk", and this produces the same error message

Nothing I have tried gets me past this brick wall.  Can anyone please suggest a solution?

Thanks in anticipation 😳 


Posted : 11/10/2022 5:29 pm